• Newslink SSL error: Giganews

    From Bob Roberts@VERT/HOVAL to Digital Man on Saturday, June 26, 2021 14:34:18
    Re: Newslink SSL error: Giganews
    By: Digital Man to Bob Roberts on Thu Jun 24 2021 05:41 pm

    Did you setup LetSyncrypt successfully? If not, you'll be using a "self-signed" certificate which giganews likely doesn't like. Either:

    1. Setup/use LetSyncrypt, or
    2. Don't use NNTPS (use plain NNTP instead)

    Additionally, Vertrauen posts NNTP messages to astraweb using NewsLink, no problem. <shrug> --

    Ok. I had no idea that my own self-signed cert could be causing this issue. I have now run LetSyncrypt, and it has completed successfully. I now have values under [State] for DomainHash and Host in letsyncrypt.ini. I can see what I think is my legit cert in /sbbs/ctrl/ssl.cert.

    However, when I goto HTTPS in my browser, it's still using the "mybbs.com" certificate. I've tried restarting SBBS multiple times, have rerun LetSyncrypt multiple times.

    Any idea why HTTPS would still be using the old cert?

    Bob Roberts

    ---
    Synchronet Halls of Valhalla =San=Francisco= hovalbbs.com:2333
  • From Bob Roberts@VERT/HOVAL to Digital Man on Saturday, June 26, 2021 14:49:56
    Re: Newslink SSL error: Giganews
    By: Bob Roberts to Digital Man on Sat Jun 26 2021 02:34 pm

    However, when I goto HTTPS in my browser, it's still using the "mybbs.com" certificate. I've tried restarting SBBS multiple times, have rerun LetSyncrypt multiple times.

    Any idea why HTTPS would still be using the old cert?

    And.... I rebooted my box. Now it's working perfectly. <sigh>
    All good.

    Bob Roberts

    ---
    Synchronet Halls of Valhalla =San=Francisco= hovalbbs.com:2333