• Re: SDL Video Initializat

    From paulie420@VERT/BEERS20 to disloops on Friday, August 06, 2021 03:54:00
    After installing SyncTerm on an AWS EC2 instance running Amazon Linux which is based on RHEL, I get this message:

    SDL Video Initialization Failed

    $ sudo yum install gcc
    $ sudo yum install patch
    $ sudo yum install ncurses-devel
    $ sudo yum install SDL2-devel

    Try setting the SDL_VIDEODRIVER environment variable to the value of dum (e.g. EXPORT SDL_VIDEODRIVER=dummy).

    I am seeing the same error message. Here is the scenario:
    $ export SDL_VIDEODRIVER=dummy
    $ printenv SDL_VIDEODRIVER
    dummy
    $ syncterm
    [...program starts and I exit with ESC...]
    SDL Video Initialization Failed

    So syncterm starts normally but when I return to the console after exiting, I see the error message. This EC2 instance has no "/dev/dri" directory, does that have something to do with the problem?
    @disloops

    Wasn't the SDL needed SDL1 & SDL1-dev?? I could be wrong, but I think thats what get her rocking for me on some ubuntu flavor..



    |07p|15AULIE|1142|07o
    |08.........
  • From Digital Man@VERT to paulie420 on Friday, August 06, 2021 10:45:02
    Re: Re: SDL Video Initializat
    By: paulie420 to disloops on Fri Aug 06 2021 03:54 am

    Wasn't the SDL needed SDL1 & SDL1-dev?? I could be wrong, but I think thats what get her rocking for me on some ubuntu flavor..

    As of SyncTERM v1.2 (now in alpha testing), SDL2 is used (not SDL1).
    --
    digital man

    Synchronet "Real Fact" #3:
    Synchronet version 2 was written in C and 8086 assembly programming languages. Norco, CA WX: 79.5F, 60.0% humidity, 1 mph WNW wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From paul lee@VERT to Digital Man on Friday, August 06, 2021 11:21:33
    Wasn't the SDL needed SDL1 & SDL1-dev?? I could be wrong, but I think t what get her rocking for me on some ubuntu flavor..

    As of SyncTERM v1.2 (now in alpha testing), SDL2 is used (not SDL1).
    digital man

    Thanks, DM - maybe thats why I am still plunking around with 1.1; i'll give 1.2+ a go again... thanks for that response - didn't mean to help with bad info.



    |07p|15AULIE|1142|07o
    |08.........
    --- Mystic BBS v1.12 A47 2021/08/05 (Raspberry Pi/32)
    * Origin: 2o fOr beeRS bbS>>20ForBeers.com:1337 (1:105/420)
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Tracker1@VERT/TRN to paul lee on Sunday, September 05, 2021 12:01:14
    On 8/6/2021 11:21 AM, paul lee wrote:

    Thanks, DM - maybe thats why I am still plunking around with 1.1;
    i'll > give 1.2+ a go again... thanks for that response - didn't mean to
    help
    with bad info.

    Can you build/run without SDL installed? Otherwise, try forcing ncurses
    mode with the command-line switch.
    --
    Michael J. Ryan - tracker1@roughneckbbs.com

    ---
    Synchronet Roughneck BBS - roughneckbbs.com