• Segfault

    From LAMBDA@VERT to All on Wednesday, November 16, 2022 20:25:23
    So I just built the source for SynchronetBBS on my raspi 4B. the config program runs fine, but when I attempt to run the actual bbs service, it segfaults. running a journalctl on it only shows that it was able to log that WSS was listening to it's sockets before it segfaulted. Forwarding the ports in the router ultimately got me no closer to solving this. Any advice on how to get it running, or what I can do next ho further pinpoint where it's messing up at? any help or advice is greatly appreciated! -Lambda

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From LAMBDA@VERT to All on Thursday, November 17, 2022 07:40:05
    For the actual build, I followed the directions shown on the wiki, but replaced the packages with their arm64 counterparts, if that might be a factor.

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to LAMBDA on Thursday, November 17, 2022 09:54:08
    Re: Segfault
    By: LAMBDA to All on Wed Nov 16 2022 08:25 pm

    So I just built the source for SynchronetBBS on my raspi 4B. the config program runs fine, but when I attempt to run the actual bbs service, it segfaults. running a journalctl on it only shows that it was able to log that WSS was listening to it's sockets before it segfaulted. Forwarding the ports in the router ultimately got me no closer to solving this. Any advice on how to get it running, or what I can do next ho further pinpoint where it's messing up at? any help or advice is greatly appreciated! -Lambda

    https://wiki.synchro.net/howto:gdb
    --
    digital man (rob)

    Synchronet "Real Fact" #113:
    Weedpuller "Assassin" http://youtu.be/opw9RPUOcv8
    Norco, CA WX: 67.9F, 17.0% humidity, 0 mph E wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From Digital Man@VERT to LAMBDA on Thursday, November 17, 2022 09:54:40
    Re: Segfault
    By: LAMBDA to All on Thu Nov 17 2022 07:40 am

    For the actual build, I followed the directions shown on the wiki, but replaced the packages with their arm64 counterparts, if that might be a factor.

    Which packages? It's most likely an issue with libmozjs.
    --
    digital man (rob)

    Synchronet/BBS Terminology Definition #6:
    BBS = Bulletin Board System
    Norco, CA WX: 67.9F, 17.0% humidity, 0 mph E wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From LAMBDA@VERT to Digital Man on Thursday, November 17, 2022 12:39:57
    I used the arm64 version of libffi, and both the mozjs packages. I've since attempted to rebuild using the armhf packages, and now get a "jsversion.h: no such file or directory" error when it attempts to compile ansiterm.cpp. I'm probably gonna reflash my pi and start from scratch, as at this point I fear that I may have made a irrecoverable error that will now prevent it from building. I'll try running through everything one last time before doing so though. I'll keep you posted. -Lambda

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net