• SMTP outbound mail from a mail client

    From deon@VERT/ALTERANT to Digital Man on Saturday, February 04, 2023 22:53:27
    Hey DM,

    I just setup using POP and SMTP via Mac mail with Synchronet (its great that SBBS can do POP/SMTP email)...

    I sent an email today, to: User One <xxxx@4ma.xyz>, with a cc: User Two <yyyy@bbs.nz> from mac mail.

    When it sent I watched the logs and noticed this:

    mail 0073 SMTP <deon> deon relaying to external mail service: 4ma.xyz
    mail 0073 SMTP <deon> deon relaying to external mail service: bbs.nz
    mail 0073 SMTP <deon> Receiving mail message from <xxxx@xxx.dege.au> to <xxxx@bbs.nz>
    mail 0073 SMTP <deon> End of message (body: 563 lines, 30587 bytes, header: 13 lines, 590 bytes)
    mail 0073 SMTP <deon> Added message header #5548 from 'Deon George' #1 to <xxxx@4ma.xyz>
    mail 0073 SMTP <deon> Added message header #5549 from 'Deon George' #1 to <yyyy@bbs.nz>
    mail 0000 SEND Message #5548 (374 of 375) from 'Deon George' #1 to 'User One' <xxxx@4ma.xyz>
    mail 0086 SEND/TLS Successfully sent message #5548 (30589 bytes, 564 lines) from 'Deon George' #1 to 'User One' <xxxx@4ma.xyz>
    mail 0000 SEND Message #5549 (375 of 375) from 'Deon George' #1 to 'User One' <yyyy@bbs.nz>
    mail 0086 SEND/TLS Successfully sent message #5549 (30589 bytes, 564 lines) from 'Deon George' #1 to 'User One' <yyyy@bbs.nz>

    Notice that the log records both outbound emails as "User One", instead of the email to @bbs.nz should be "User Two" (on the last line above).

    So I logged on and looked at sent mails via the ;MAIL, and noticed something completely different:

    The message was recorded twice (OK), the first one rendered correctly (the receipients named matched the email address), the second one was different:

    旼컴컴컴컴컴컴컴컴컴컴컴퀭頰
    Subj: Re: fsxnet application
    Attr: Deleted Sent KillSent
    To : User One (yyyy@bbs.nz)
    CC : User Two <yyyy@bbs.nz>
    From: Deon George #1 (xxxx@xxx.dege.au)
    Date: Sat Feb 04 2023 09:50 pm UTC+11:00 (35 minutes ago)


    The "To" has the correct name, but the wrong email address.

    I checked my SMTP log, and it appears the mails were sent to the right people - not sure if their names were correct though...?


    ...依俺

    ---
    Synchronet AnsiTEX bringing back videotex but with ANSI
  • From Digital Man@VERT to deon on Saturday, February 04, 2023 13:35:38
    Re: SMTP outbound mail from a mail client
    By: deon to Digital Man on Sat Feb 04 2023 10:53 pm

    Hey DM,

    I just setup using POP and SMTP via Mac mail with Synchronet (its great that SBBS can do POP/SMTP email)...

    I sent an email today, to: User One <xxxx@4ma.xyz>, with a cc: User Two <yyyy@bbs.nz> from mac mail.

    When it sent I watched the logs and noticed this:

    mail 0073 SMTP <deon> deon relaying to external mail service: 4ma.xyz
    mail 0073 SMTP <deon> deon relaying to external mail service: bbs.nz
    mail 0073 SMTP <deon> Receiving mail message from <xxxx@xxx.dege.au> to <xxxx@bbs.nz>
    mail 0073 SMTP <deon> End of message (body: 563 lines, 30587 bytes, header: 13 lines, 590 bytes)
    mail 0073 SMTP <deon> Added message header #5548 from 'Deon George' #1 to <xxxx@4ma.xyz>
    mail 0073 SMTP <deon> Added message header #5549 from 'Deon George' #1 to <yyyy@bbs.nz>
    mail 0000 SEND Message #5548 (374 of 375) from 'Deon George' #1 to 'User One' <xxxx@4ma.xyz>
    mail 0086 SEND/TLS Successfully sent message #5548 (30589 bytes, 564 lines) from 'Deon George' #1 to 'User One' <xxxx@4ma.xyz>
    mail 0000 SEND Message #5549 (375 of 375) from 'Deon George' #1 to 'User One' <yyyy@bbs.nz>
    mail 0086 SEND/TLS Successfully sent message #5549 (30589 bytes, 564 lines) from 'Deon George' #1 to 'User One' <yyyy@bbs.nz>

    Notice that the log records both outbound emails as "User One", instead of the email to @bbs.nz should be "User Two" (on the last line above).

    Yeah, the log messages for multiple recipients of a single message are a bit wonky. That's a known issue, but not a particularly high priority to "fix".

    So I logged on and looked at sent mails via the ;MAIL, and noticed something completely different:

    The message was recorded twice (OK), the first one rendered correctly (the receipients named matched the email address), the second one was different:

    旼컴컴컴컴컴컴컴컴컴컴컴퀭頰
    Subj: Re: fsxnet application
    Attr: Deleted Sent KillSent
    To : User One (yyyy@bbs.nz)
    CC : User Two <yyyy@bbs.nz>
    From: Deon George #1 (xxxx@xxx.dege.au)
    Date: Sat Feb 04 2023 09:50 pm UTC+11:00 (35 minutes ago)


    The "To" has the correct name, but the wrong email address.

    I checked my SMTP log, and it appears the mails were sent to the right people - not sure if their names were correct though...?

    If you enable debug level log output and the DEBUG_TX option in the [mail] section of ctrl/sbbs.ini, you'll get to see all the message headers as they were sent.
    --
    digital man (rob)

    This Is Spinal Tap quote #11:
    Nigel Tufnel: No. no. That's it, you've seen enough of that one.
    Norco, CA WX: 68.9F, 34.0% humidity, 10 mph SSE wind, 0.00 inches rain/24hrs

    ---
    Synchronet Vertrauen Home of Synchronet [vert/cvs/bbs].synchro.net
  • From jacobcart@VERT/ZRUSPAS to Digital Man on Monday, February 06, 2023 18:57:58
    wow great
    ---
    Synchronet Zruspa's BBS